TLS Upgrade: Everything you need to know

This TLS update will occur on the 25th of February, 2021.

From the 25th of February, SMSGlobal will no longer have TLS 1.0 and 1.1 as default protocols. To maintain the highest level of security and protect your data, TLS 1.2 will be the new default for all HTTPS connections.

This change will impact all types of postbacks, including Delivery Receipt postbacks and Incoming Message postbacks.

What action do you need to take?

Customers using TLS 1.0 and 1.1 will need to ensure their applications support TLS 1.2 by the 25th of February, 2021.

My system only supports TLS 1.0 or 1.1. What do I do?

If your environment requires TLS 1.0 or 1.1, please get in contact with SMSGlobal’s dedicated support staff. Requests to maintain TLS versions 1.0 and 1.1 on your account must be handled by a SMSGlobal tech specialist.

What will happen if I don’t update to TLS 1.2?

If your system doesn’t support TLS 1.2 by February 25, 2021, you may experience service disruptions. Ensure your connection supports TLS 1.2 to guarantee uninterrupted postbacks.

Contact us

Couldn't find the information you needed on this page?

Get in touch with our Customer Success team by filling out the form below

Loading Form